2023年01月07日

結論としては、、、(失敗談) archlinux(archbang)に、unity-7.6を載せる件。

archlinuxは、他人のスピードを顧みずで、
とっとことっとこ先に行きます。
arch-unityのrepoがarchlinuxのスピードに
追いついていないがために、
今回の不具合が生じている、ということに
してしまいました。

サードパーティもので、archlinuxに
完全対応してくのは、ほとんどムリな諸行。
フォントとか静的なファイルなら、
影響を受けませんが。

公式採用されない限り、一時の出来事で
終わってしまうでしょうね。

試しに、pacman.confのrepo設定を
arch-unityだけにして、unity-metaの
インストールをテストした結果がこちら。

$ sudo pacman -S unity-meta
依存関係を解決しています...
警告: "appstream-glib" を解決できません、"unity" の依存
警告: "libwnck3" を解決できません、"bamf-ubuntu" の依存
警告: "python-lxml" を解決できません、"bamf-ubuntu" の依存
警告: "bamf-ubuntu" を解決できません、"unity" の依存
警告: "boost" を解決できません、"unity" の依存
警告: "boost-libs" を解決できません、"compiz-ubuntu" の依存
警告: "libwnck3" を解決できません、"compiz-ubuntu" の依存
警告: "metacity" を解決できません、"compiz-ubuntu" の依存
警告: "protobuf" を解決できません、"compiz-ubuntu" の依存
警告: "gnome-desktop" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "libgweather-4" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geocode-glib" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geoclue" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "gnome-settings-daemon" を解決できません、"compiz-ubuntu" の依存
警告: "compiz-ubuntu" を解決できません、"unity" の依存
警告: "clutter-gtk" を解決できません、"unity" の依存
警告: "gjs" を解決できません、"unity" の依存
警告: "gnome-desktop" を解決できません、"unity" の依存
警告: "libgnomekbd" を解決できません、"gnome-screensaver-ubuntu" の依存
警告: "gnome-desktop" を解決できません、"gnome-screensaver-ubuntu" の依存
警告: "gnome-screensaver" を解決できません、"unity" の依存
警告: "gnome-desktop" を解決できません、"gnome-session-bin" の依存
警告: "gnome-session-bin" を解決できません、"unity" の依存
警告: "libwnck3" を解決できません、"bamf-ubuntu" の依存
警告: "python-lxml" を解決できません、"bamf-ubuntu" の依存
警告: "bamf-ubuntu" を解決できません、"hud" の依存
警告: "gsettings-qt" を解決できません、"hud" の依存
警告: "hud" を解決できません、"unity" の依存
警告: "smbclient" を解決できません、"gnome-vfs" の依存
警告: "gnome-vfs" を解決できません、"libgnome" の依存
警告: "libidl2" を解決できません、"orbit2" の依存
警告: "orbit2" を解決できません、"libbonobo" の依存
警告: "libbonobo" を解決できません、"libgnome" の依存
警告: "libgnome" を解決できません、"libbonoboui" の依存
警告: "libbonoboui" を解決できません、"libgnomeui" の依存
警告: "libgnome-keyring" を解決できません、"libgnomeui" の依存
警告: "libgnomeui" を解決できません、"unity" の依存
警告: "glew" を解決できません、"nux" の依存
警告: "nux" を解決できません、"unity" の依存
警告: "telepathy-glib" を解決できません、"zeitgeist-ubuntu" の依存
警告: "xapian-core" を解決できません、"zeitgeist-ubuntu" の依存
警告: "zeitgeist" を解決できません、"unity" の依存
警告: "python-pyxdg" を解決できません、"unity" の依存
警告: "notify-osd" を解決できません、"unity" の依存
警告: "unity" を解決できません、"unity-meta" の依存
警告: "boost-libs" を解決できません、"compiz-ubuntu" の依存
警告: "libwnck3" を解決できません、"compiz-ubuntu" の依存
警告: "metacity" を解決できません、"compiz-ubuntu" の依存
警告: "protobuf" を解決できません、"compiz-ubuntu" の依存
警告: "gnome-desktop" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "libgweather-4" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geocode-glib" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geoclue" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "gnome-settings-daemon" を解決できません、"compiz-ubuntu" の依存
警告: "compiz-ubuntu" を解決できません、"unity-meta" の依存
警告: "glew" を解決できません、"nux" の依存
警告: "nux" を解決できません、"unity-meta" の依存
警告: "gnome-desktop" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "libgweather-4" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geocode-glib" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geoclue" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "gnome-settings-daemon-ubuntu" を解決できません、"unity-settings-daemon" の依存
警告: "fcitx" を解決できません、"unity-settings-daemon" の依存
警告: "gperf" を解決できません、"unity-settings-daemon" の依存
警告: "libappindicator-gtk3" を解決できません、"unity-settings-daemon" の依存
警告: "unity-settings-daemon" を解決できません、"unity-session" の依存
警告: "unity-session" を解決できません、"unity-meta" の依存
警告: "libayatana-appindicator" を解決できません、"unity-meta" の依存
警告: "libappindicator-gtk3" を解決できません、"indicator-application" の依存
警告: "indicator-application" を解決できません、"unity-meta" の依存
警告: "bluez" を解決できません、"indicator-bluetooth" の依存
警告: "indicator-bluetooth" を解決できません、"unity-meta" の依存
警告: "accountsservice" を解決できません、"indicator-keyboard" の依存
警告: "fcitx" を解決できません、"indicator-keyboard" の依存
警告: "gnome-desktop" を解決できません、"indicator-keyboard" の依存
警告: "gucharmap" を解決できません、"indicator-keyboard" の依存
警告: "libgee" を解決できません、"indicator-keyboard" の依存
警告: "libgnomekbd" を解決できません、"indicator-keyboard" の依存
警告: "accountsservice" を解決できません、"unity-control-center" の依存
警告: "cups-pk-helper" を解決できません、"unity-control-center" の依存
警告: "fcitx" を解決できません、"unity-control-center" の依存
警告: "gnome-menus" を解決できません、"unity-control-center" の依存
警告: "libsoup" を解決できません、"libtimezonemap" の依存
警告: "libtimezonemap" を解決できません、"unity-control-center" の依存
警告: "libappindicator-gtk3" を解決できません、"network-manager-applet-ubuntu" の依存
警告: "network-manager-applet-ubuntu" を解決できません、"unity-control-center" の依存
警告: "libpwquality" を解決できません、"unity-control-center" の依存
警告: "smbclient" を解決できません、"unity-control-center" の依存
警告: "gnome-color-manager" を解決できません、"unity-control-center" の依存
警告: "libgnomekbd" を解決できません、"unity-control-center" の依存
警告: "grilo" を解決できません、"unity-control-center" の依存
警告: "clutter-gtk" を解決できません、"unity-control-center" の依存
警告: "gnome-desktop" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "libgweather-4" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geocode-glib" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geoclue" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "gnome-settings-daemon-ubuntu" を解決できません、"unity-settings-daemon" の依存
警告: "fcitx" を解決できません、"unity-settings-daemon" の依存
警告: "gperf" を解決できません、"unity-settings-daemon" の依存
警告: "libappindicator-gtk3" を解決できません、"unity-settings-daemon" の依存
警告: "unity-settings-daemon" を解決できません、"unity-control-center" の依存
警告: "system-config-printer" を解決できません、"unity-control-center" の依存
警告: "webkit2gtk" を解決できません、"unity-control-center" の依存
警告: "unity-control-center" を解決できません、"indicator-keyboard" の依存
警告: "indicator-keyboard" を解決できません、"unity-meta" の依存
警告: "accountsservice" を解決できません、"unity-control-center" の依存
警告: "cups-pk-helper" を解決できません、"unity-control-center" の依存
警告: "fcitx" を解決できません、"unity-control-center" の依存
警告: "gnome-menus" を解決できません、"unity-control-center" の依存
警告: "libsoup" を解決できません、"libtimezonemap" の依存
警告: "libtimezonemap" を解決できません、"unity-control-center" の依存
警告: "libappindicator-gtk3" を解決できません、"network-manager-applet-ubuntu" の依存
警告: "network-manager-applet-ubuntu" を解決できません、"unity-control-center" の依存
警告: "libpwquality" を解決できません、"unity-control-center" の依存
警告: "smbclient" を解決できません、"unity-control-center" の依存
警告: "gnome-color-manager" を解決できません、"unity-control-center" の依存
警告: "libgnomekbd" を解決できません、"unity-control-center" の依存
警告: "grilo" を解決できません、"unity-control-center" の依存
警告: "clutter-gtk" を解決できません、"unity-control-center" の依存
警告: "gnome-desktop" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "libgweather-4" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geocode-glib" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geoclue" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "gnome-settings-daemon-ubuntu" を解決できません、"unity-settings-daemon" の依存
警告: "fcitx" を解決できません、"unity-settings-daemon" の依存
警告: "gperf" を解決できません、"unity-settings-daemon" の依存
警告: "libappindicator-gtk3" を解決できません、"unity-settings-daemon" の依存
警告: "unity-settings-daemon" を解決できません、"unity-control-center" の依存
警告: "system-config-printer" を解決できません、"unity-control-center" の依存
警告: "webkit2gtk" を解決できません、"unity-control-center" の依存
警告: "unity-control-center" を解決できません、"indicator-power" の依存
警告: "indicator-power" を解決できません、"unity-meta" の依存
警告: "gnome-desktop" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "libgweather-4" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geocode-glib" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geoclue" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "gnome-settings-daemon" を解決できません、"indicator-session" の依存
警告: "indicator-session" を解決できません、"unity-meta" の依存
警告: "libappindicator-gtk3" を解決できません、"indicator-appmenu" の依存
警告: "libwnck3" を解決できません、"bamf-ubuntu" の依存
警告: "python-lxml" を解決できません、"bamf-ubuntu" の依存
警告: "bamf-ubuntu" を解決できません、"indicator-appmenu" の依存
警告: "indicator-appmenu" を解決できません、"unity-meta" の依存
警告: "evolution-data-server" を解決できません、"indicator-datetime" の依存
警告: "accountsservice" を解決できません、"indicator-messages" の依存
警告: "indicator-messages" を解決できません、"indicator-datetime" の依存
警告: "libaccounts-glib" を解決できません、"indicator-datetime" の依存
警告: "libsoup" を解決できません、"libtimezonemap" の依存
警告: "libtimezonemap" を解決できません、"indicator-datetime" の依存
警告: "accountsservice" を解決できません、"unity-control-center" の依存
警告: "cups-pk-helper" を解決できません、"unity-control-center" の依存
警告: "fcitx" を解決できません、"unity-control-center" の依存
警告: "gnome-menus" を解決できません、"unity-control-center" の依存
警告: "libsoup" を解決できません、"libtimezonemap" の依存
警告: "libtimezonemap" を解決できません、"unity-control-center" の依存
警告: "libappindicator-gtk3" を解決できません、"network-manager-applet-ubuntu" の依存
警告: "network-manager-applet-ubuntu" を解決できません、"unity-control-center" の依存
警告: "libpwquality" を解決できません、"unity-control-center" の依存
警告: "smbclient" を解決できません、"unity-control-center" の依存
警告: "gnome-color-manager" を解決できません、"unity-control-center" の依存
警告: "libgnomekbd" を解決できません、"unity-control-center" の依存
警告: "grilo" を解決できません、"unity-control-center" の依存
警告: "clutter-gtk" を解決できません、"unity-control-center" の依存
警告: "gnome-desktop" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "libgweather-4" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geocode-glib" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geoclue" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "gnome-settings-daemon-ubuntu" を解決できません、"unity-settings-daemon" の依存
警告: "fcitx" を解決できません、"unity-settings-daemon" の依存
警告: "gperf" を解決できません、"unity-settings-daemon" の依存
警告: "libappindicator-gtk3" を解決できません、"unity-settings-daemon" の依存
警告: "unity-settings-daemon" を解決できません、"unity-control-center" の依存
警告: "system-config-printer" を解決できません、"unity-control-center" の依存
警告: "webkit2gtk" を解決できません、"unity-control-center" の依存
警告: "unity-control-center" を解決できません、"indicator-datetime" の依存
警告: "indicator-datetime" を解決できません、"unity-meta" の依存
警告: "accountsservice" を解決できません、"indicator-messages" の依存
警告: "indicator-messages" を解決できません、"unity-meta" の依存
警告: "cups" を解決できません、"indicator-printers" の依存
警告: "indicator-printers" を解決できません、"unity-meta" の依存
警告: "accountsservice" を解決できません、"indicator-sound" の依存
警告: "libgee" を解決できません、"indicator-sound" の依存
警告: "accountsservice" を解決できません、"unity-control-center" の依存
警告: "cups-pk-helper" を解決できません、"unity-control-center" の依存
警告: "fcitx" を解決できません、"unity-control-center" の依存
警告: "gnome-menus" を解決できません、"unity-control-center" の依存
警告: "libsoup" を解決できません、"libtimezonemap" の依存
警告: "libtimezonemap" を解決できません、"unity-control-center" の依存
警告: "libappindicator-gtk3" を解決できません、"network-manager-applet-ubuntu" の依存
警告: "network-manager-applet-ubuntu" を解決できません、"unity-control-center" の依存
警告: "libpwquality" を解決できません、"unity-control-center" の依存
警告: "smbclient" を解決できません、"unity-control-center" の依存
警告: "gnome-color-manager" を解決できません、"unity-control-center" の依存
警告: "libgnomekbd" を解決できません、"unity-control-center" の依存
警告: "grilo" を解決できません、"unity-control-center" の依存
警告: "clutter-gtk" を解決できません、"unity-control-center" の依存
警告: "gnome-desktop" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "libgweather-4" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geocode-glib" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geoclue" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "gnome-settings-daemon-ubuntu" を解決できません、"unity-settings-daemon" の依存
警告: "fcitx" を解決できません、"unity-settings-daemon" の依存
警告: "gperf" を解決できません、"unity-settings-daemon" の依存
警告: "libappindicator-gtk3" を解決できません、"unity-settings-daemon" の依存
警告: "unity-settings-daemon" を解決できません、"unity-control-center" の依存
警告: "system-config-printer" を解決できません、"unity-control-center" の依存
警告: "webkit2gtk" を解決できません、"unity-control-center" の依存
警告: "unity-control-center" を解決できません、"indicator-sound" の依存
警告: "indicator-sound" を解決できません、"unity-meta" の依存
警告: "libgee" を解決できません、"unity-scope-home" の依存
警告: "libsoup" を解決できません、"unity-scope-home" の依存
警告: "unity-scope-home" を解決できません、"unity-meta" の依存
警告: "gnome-menus" を解決できません、"unity-lens-applications" の依存
警告: "libgee" を解決できません、"unity-lens-applications" の依存
警告: "xapian-core" を解決できません、"unity-lens-applications" の依存
警告: "telepathy-glib" を解決できません、"zeitgeist-ubuntu" の依存
警告: "xapian-core" を解決できません、"zeitgeist-ubuntu" の依存
警告: "zeitgeist-ubuntu" を解決できません、"unity-lens-applications" の依存
警告: "unity-lens-applications" を解決できません、"unity-meta" の依存
警告: "telepathy-glib" を解決できません、"zeitgeist-ubuntu" の依存
警告: "xapian-core" を解決できません、"zeitgeist-ubuntu" の依存
警告: "zeitgeist-ubuntu" を解決できません、"unity-lens-files" の依存
警告: "libgee" を解決できません、"unity-lens-files" の依存
警告: "libxdg-basedir" を解決できません、"unity-lens-files" の依存
警告: "python-pyxdg" を解決できません、"unity-lens-files" の依存
警告: "unity-lens-files" を解決できません、"unity-meta" の依存
警告: "libgee" を解決できません、"unity-lens-music" の依存
警告: "liboauth" を解決できません、"unity-lens-music" の依存
警告: "libsoup" を解決できません、"unity-lens-music" の依存
警告: "unity-lens-music" を解決できません、"unity-meta" の依存
警告: "python-httplib2" を解決できません、"unity-lens-photos" の依存
警告: "python-oauthlib" を解決できません、"unity-lens-photos" の依存
警告: "libsoup" を解決できません、"unity-lens-photos" の依存
警告: "unity-lens-photos" を解決できません、"unity-meta" の依存
警告: "libgee" を解決できません、"unity-lens-video" の依存
警告: "libsoup" を解決できません、"unity-lens-video" の依存
警告: "libgee" を解決できません、"unity-lens-music" の依存
警告: "liboauth" を解決できません、"unity-lens-music" の依存
警告: "libsoup" を解決できません、"unity-lens-music" の依存
警告: "unity-lens-music" を解決できません、"unity-lens-video" の依存
警告: "unity-lens-video" を解決できません、"unity-meta" の依存
警告: "gtk-engine-murrine" を解決できません、"yaru-gtk-theme" の依存
警告: "gnome-themes-extra" を解決できません、"yaru-gtk-theme" の依存
警告: "yaru-gtk-theme" を解決できません、"unity-settings" の依存
警告: "ttf-ubuntu-font-family" を解決できません、"unity-settings" の依存
警告: "unity-settings" を解決できません、"unity-meta" の依存
警告: "gnome-terminal" を解決できません、"unity-meta" の依存
警告: "bluez" を解決できません、"unity-meta" の依存
警告: "nemo" を解決できません、"unity-meta" の依存
警告: "libreoffice" を解決できません、"unity-meta" の依存
警告: "notify-osd" を解決できません、"unity-tweak-tool" の依存
警告: "python-xdg" を解決できません、"unity-tweak-tool" の依存
警告: "appstream-glib" を解決できません、"unity" の依存
警告: "libwnck3" を解決できません、"bamf-ubuntu" の依存
警告: "python-lxml" を解決できません、"bamf-ubuntu" の依存
警告: "bamf-ubuntu" を解決できません、"unity" の依存
警告: "boost" を解決できません、"unity" の依存
警告: "boost-libs" を解決できません、"compiz-ubuntu" の依存
警告: "libwnck3" を解決できません、"compiz-ubuntu" の依存
警告: "metacity" を解決できません、"compiz-ubuntu" の依存
警告: "protobuf" を解決できません、"compiz-ubuntu" の依存
警告: "gnome-desktop" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "libgweather-4" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geocode-glib" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "geoclue" を解決できません、"gnome-settings-daemon-ubuntu" の依存
警告: "gnome-settings-daemon" を解決できません、"compiz-ubuntu" の依存
警告: "compiz-ubuntu" を解決できません、"unity" の依存
警告: "clutter-gtk" を解決できません、"unity" の依存
警告: "gjs" を解決できません、"unity" の依存
警告: "gnome-desktop" を解決できません、"unity" の依存
警告: "libgnomekbd" を解決できません、"gnome-screensaver-ubuntu" の依存
警告: "gnome-desktop" を解決できません、"gnome-screensaver-ubuntu" の依存
警告: "gnome-screensaver" を解決できません、"unity" の依存
警告: "gnome-desktop" を解決できません、"gnome-session-bin" の依存
警告: "gnome-session-bin" を解決できません、"unity" の依存
警告: "libwnck3" を解決できません、"bamf-ubuntu" の依存
警告: "python-lxml" を解決できません、"bamf-ubuntu" の依存
警告: "bamf-ubuntu" を解決できません、"hud" の依存
警告: "gsettings-qt" を解決できません、"hud" の依存
警告: "hud" を解決できません、"unity" の依存
警告: "smbclient" を解決できません、"gnome-vfs" の依存
警告: "gnome-vfs" を解決できません、"libgnome" の依存
警告: "libidl2" を解決できません、"orbit2" の依存
警告: "orbit2" を解決できません、"libbonobo" の依存
警告: "libbonobo" を解決できません、"libgnome" の依存
警告: "libgnome" を解決できません、"libbonoboui" の依存
警告: "libbonoboui" を解決できません、"libgnomeui" の依存
警告: "libgnome-keyring" を解決できません、"libgnomeui" の依存
警告: "libgnomeui" を解決できません、"unity" の依存
警告: "glew" を解決できません、"nux" の依存
警告: "nux" を解決できません、"unity" の依存
警告: "telepathy-glib" を解決できません、"zeitgeist-ubuntu" の依存
警告: "xapian-core" を解決できません、"zeitgeist-ubuntu" の依存
警告: "zeitgeist" を解決できません、"unity" の依存
警告: "python-pyxdg" を解決できません、"unity" の依存
警告: "notify-osd" を解決できません、"unity" の依存
警告: "unity" を解決できません、"unity-tweak-tool" の依存
警告: "unity-tweak-tool" を解決できません、"unity-meta" の依存
警告: "pluma" を解決できません、"unity-meta" の依存
警告: "eom" を解決できません、"unity-meta" の依存
警告: "atril" を解決できません、"unity-meta" の依存
警告: "engrampa" を解決できません、"unity-meta" の依存
:: 依存関係を解決できないために以下のパッケージを更新できません:
unity-meta
:: 更新のために上記のパッケージをスキップしますか? [y/N]

archlinuxの公式repoとの入り組み具合は想像以上で、
こりゃあかんわ。の世界でした。unity-meta関連、
archlinux用にパッケージ化されてから、おそらく
ほとんど更新されていないんじゃないいかと。

インストール時には問題なく、途中で、
デスクトップが出なくなった、みたいな
ケースがあるんじゃないか、と思います。


posted by ブログ開設者 at 08:02| Comment(0) | linux | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント:

※ブログオーナーが承認したコメントのみ表示されます。