2015年02月16日

更新不具合、暫定的措置。chakra−201405−descartes−x86_64

更新すると、
エラー: 処理の準備に失敗しました (依存関係を解決できませんでした)
:: python-gobject: pygobject-devel=3.12.2 を必要としています

が出て、更新できないの問題。

まだ、根本的なことは、解決していない。
問題以外のその他の更新は、できるようになった。
以下、その方法。

$ sudo nano /etc/pacman.conf
IgnorePkg = python2-gobject pygobject-devel
部分を追記、保存。
で、更新できるようになる。更新後もう一度やると、

$ sudo pacman -Syu
:: パッケージデータベースの同期中...
lib32 は最新です
core は最新です
platform は最新です
desktop は最新です
apps は最新です
games は最新です
extra は最新です
unstable は最新です
archlinuxfr は最新です
:: システム全体の更新を開始...
警告: pygobject-devel: パッケージの更新を無視 (3.12.2-1 => 3.14.0-1)
警告: python2-gobject: パッケージの更新を無視 (3.12.2-3 => 3.14.0-1)

警告: python2-mako: ローカル (0.9.1-2) のほうが core よりも最新です (0.9.1-1)
何も行うことがありません

chakraには、python2-gobjectは在っても、python-gobjectは、
ないみたいなんですけどね。archbangからもってきて
インストールしたけれど、errorは解消できなかった。

で、無事更新できたら、
205もの更新になった。結果、spacefmが動かなくなり、
yaourtコマンドが実行できなくなった。解決はしたが、、、。
カーネルは、linux-3.18.1-1-CHAKRA → 3.18.3-1-CHAKRA

spacefmは、オフィシャルのリポジトリからでは
インストールできなかったんだ
みたいで(失念)、新たにabs(aur)からビルドして
最新のバージョンにしたら、起動するようになった。
archに慣れない人にやり方:
$ sudo pacman -S base-devel
$ sudo pacman -S abs
$ sudo abs
$ mkdir ~/spacefm_make
$ sudo cp /var/abs/community/spacefm/PKGBUILD ~/spacefm_make
$ sudo cp /var/abs/community/spacefm/spacefm.install ~/spacefm_make
$ sudo cp /var/abs/community/spacefm/spacefm-0.9.4-glib-2.41.patch ~/spacefm_make
$ cd ~/spacefm_make
$ makepkg -s
$ sudo pacman -U ~/spacefm-0.9.4-3-x86_64.pkg.tar.xz



yaourtコマンドの動作修復:
error表示から察して下記のようにしたら、動いた。
$ cd /usr/lib
$ sudo ln -s libalpm.so.8.0.2 libalpm.so.9


ってことで、arch本家筋に比べると、
じつにいろいろ起こります。

しっかし、errorの件、何が起こっているのか、
判らんなあ。


posted by ブログ開設者 at 23:45| Comment(0) | linux | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント: