2022年10月28日

archlinux(archbang-i3)におけるvlc(dvb)の現状。

pt3カード受信に伴うvlcの状況です。

vlcが、ltsカーネルで映らなかったので、
chaotic-aurからの
vlc-gitに変更しました(pacmanインストール)。
バージョン的には、4.0.0-dev。
結果、映るようになりましたが、数分すると、
クラッシュする状態でした。

$ vlc とコマンド起動して、ライブラリがないとの表示が
多行出ました。それらをすべてpacmanインストール。
(名前をアレンジしないと見つからないこともあります。
すべて名前を載せるつもりが、システムフリーズして叶わずでした。
パッケージの数は12〜13)

それでも、vlcがクラッシュするので、
nouveauでのモニター表示から、
nvidiaドライバに変更しました。継続して映るように
なりました。いまのところ30分無事。

コマンド起動している状態で、
[mpeg2video @ 0x7fa40000ff40] hardware accelerator failed to decode first field
の行が放映中ずっと出ています。
[00007fa410014290] avcodec decoder error: more than 26 frames of late video -> dropping frame (computer too slow ?)
が出てたりもしますね(1度だけ)。正常に動いているときは、
上のほうの行がターミナルに出ています。

i3-wmで別なワークスペースに行って、もどってくると、
映像は止まっています、必ず。ダブルクリックしてフルスクリーンに
すると、正常に映像が動き出します。タイル表示の1つに戻しても
動いています。

カーネルモジュールは、nouveauを止め、nvidia、nvidia-drm、
nvidia-modeset、mvidia-uvmをロードさせています。
nvidia-settingsは、未インストール。

smplayerのほうが、安定していいかも、ですね。
55分あまり経ちましたが、クラッシュしないで、
継続して映っていますが。

vlc-git_test_2022-10-28_10-41-47.jpg


posted by ブログ開設者 at 10:58| Comment(0) | linux | このブログの読者になる | 更新情報をチェックする

2022年10月27日

archbang32-rc-2610-i686.iso。vmware workstation player16.2.4 / sparkylinux-6.4-x86_64-xfce

archbang32の最新isoがsourceforgeに
アップロードされています。
1110バージョンはシステム起動しませんでしが、
このたびは、大丈夫でした。

カーネルは、5.19.7-arch1-1.0。
ブラウザは、netsurfです。

vmware workstation playerで、live起動したところ。
abi686-2610_2022-10-27_10-14-10.jpg

デスクトップは、openboxのまま。
インストーラーのabinstallは、存在しますが、
動きません。

状況は、/etc/sudoersファイルはあるが、
ユーザーにsudoを使う権限がないため、の模様。
$ su でrootになれたら、修正できるんですけど、
rootのパスワードが判らない。
arch、bang、abinstall、alive、ablive、rootuser
root、toor、いろいろやってみましたが、
rootになれません。
sudoersファイルが開かない限り、
abliveユーザーではなにもできないですしね。

つまり、インストールしたくても、
今回のバージョンはできない、みたいな。
pacmanも使えないので、何もできない
に近いですね。i686バージョンは
やめようモードのみどり氏の残された集中力が
どの程度か、うかがえます。


posted by ブログ開設者 at 10:42| Comment(0) | linux | このブログの読者になる | 更新情報をチェックする

2022年10月25日

archlinuxにおけるpt3(dvb)の現状。

リアルインストールのarchbangで、pt3(dvb)の状況確認。
tuneコマンドによる受信は問題なしも、
vlcでは表示できないですね。
よくあった、libdvbpsiのバージョン問題か。
downgradeコマンドで、バージョンが下げられず、
試せていませんが。

smplayerでなら、表示できています。

tune_pt3_vlc_error_2022-10-25_20-13-08.jpg

カーネルは、5.15.73-3-lts。vmware workstation
playerがデフォルトカーネルでは動かないためです。
カーネルは、earth_pt3モジュールが問題ないので
おそらく無関係だと思います。
vlcとの付き合いは長くて、不具合は
頻繁に起こってきました。


posted by ブログ開設者 at 20:58| Comment(0) | linux | このブログの読者になる | 更新情報をチェックする