2017年01月16日

arch上のvmware。archbang-lite-1216-x86_64(jwm)

これまで仮想とえいば、
virtualboxっきりしか、使ったことがなかった。

下準備:
当然のことながら、bios(h170-plus d3)をいじる。
advanced mode -> advanced ->
cpu configrationのずっと下のほう、
intel virtualization technologyを enabled に。

$ sudo pacman -S fuse gtkmm linux-headers

pgpが通らない場合、こんなオプションを付けるんだそうな。
$ yaourt yaourt --m-arg "--skippgpcheck" -S ncurses5-compat-libs


で、vmwareの本体を以下から取得。
http://www.vmware.com/products/player/playerpro-evaluation.html

VMware-Player-12.5.2-4638234.x86_64.bundle を
ダンロードする。

$ cd ~/Downloads/
$ sudo chmod 755 VMware-Player-12.5.1-4542065.x86_64.bundle
$ sudo sh VMware-Player-12.5.1-4542065.x86_64.bundle


$ sudo nano /etc/systemd/system/vmware.service
[Unit]
Description=VMware daemon
Requires=vmware-usbarbitrator.service
Before=vmware-usbarbitrator.service
After=network.target

[Service]
ExecStart=/etc/init.d/vmware start
ExecStop=/etc/init.d/vmware stop
PIDFile=/var/lock/subsys/vmware
RemainAfterExit=yes

[Install]
WantedBy=multi-user.target



$ sudo nano /etc/systemd/system/vmware-usbarbitrator.service

[Unit]
Description=VMware USB Arbitrator
Requires=vmware.service
After=vmware.service

[Service]
ExecStart=/usr/bin/vmware-usbarbitrator
ExecStop=/usr/bin/vmware-usbarbitrator --kill
RemainAfterExit=yes

[Install]
WantedBy=multi-user.target


$ sudo systemctl enable vmware.service
$ sudo systemctl enable vmware-usbarbitrator.service


$ sudo reboot

$ vmplayer

I/O warning : failed to load external entity "/etc/vmware/hostd/proxy.xml"
で起動。
failedの表示は、vmwareを使うぶんには、気にしなくていいそうだ。
消す方法もあるけれど、各自検索してください。

2017-01-16-214445_1680x1050_scrot.jpg

ホストosは、archbang-lite-beta-1216-x86_64
ゲストosは、archbang-lite-beta-1116-x86_64
2017-01-16-214536_1680x1050_scrot.jpg
ハードは、h170-plus d3 に、celeron g3900 + memory8gb

残念なことは、
入れたosの全画面表示(フルスクリーン)が
できない。vmware-toolsってものが必要なようで、
どうやったらいいのか、わからない。
ubuntu16.04でもトライしたけど、
全画面表示ふうに画面は広がるけど、
OSのデスクトップ表示は小さいまま。

カーネルは、4.8.13-1-ARCHでも動いている。
最初、4.4以下にしろ、と云われ、
4.4.42-1-ltsを使っていたけど。

最新のnutyxを試すのに、こんなトライを
やったんだけど、liveがなくてインストーラー
だけのディストロだった。インストール後の再起動で、
カーネルパニックになる。原因不明。
カーネルを4.4.42-1-ltsでやったんだけどね。
なぜかがわからない。


posted by ブログ開設者 at 22:01| Comment(0) | linux | このブログの読者になる | 更新情報をチェックする