2015年11月04日

catalyst更新。archbang-rc-20141215-x86_64

20151104現在で、ltsバージョンのカーネルが
4.1.12-1-ltsになっていた、ってことで、
catalystを最新まで更新してみた。
主な環境:aslock g31m-gs、intel core2duo e8400、msi r5770

ほぼログそのままです:

$ sudo pacman -S catalyst-utils catalyst-hook catalyst-libgl
:: catalyst-utils は IgnorePkg/IgnoreGroup です。それでもインストールしますか? [Y/n] y
:: catalyst-hook は IgnorePkg/IgnoreGroup です。それでもインストールしますか? [Y/n] y
:: catalyst-libgl は IgnorePkg/IgnoreGroup です。それでもインストールしますか? [Y/n] y
依存関係を解決しています...
衝突するパッケージがないか確認しています...
警告: 依存サイクルが検出されました:
警告: catalyst-libgl は依存パッケージ catalyst-utils の前にインストールされます
警告: 依存サイクルが検出されました:
警告: catalyst-libgl は依存パッケージ catalyst-utils の前にインストールされます

パッケージ (5) linux-lts-4.1.12-1 linux-lts-headers-4.1.12-1
catalyst-hook-15.9-2 catalyst-libgl-15.9-2
catalyst-utils-15.9-2


合計ダウンロード容量: 62.58 MiB
合計インストール容量: 262.25 MiB
最終的なアップグレード容量: 121.01 MiB

:: インストールを行いますか? [Y/n]
:: パッケージを取得します ...
linux-lts-4.1.12-1-... 56.2 MiB 953K/s 01:00 [######################] 100%
linux-lts-headers-4... 6.4 MiB 454K/s 00:14 [######################] 100%
(5/5) キーリングのキーを確認 [######################] 100%
(5/5) パッケージの整合性をチェック [######################] 100%
(5/5) パッケージファイルのロード [######################] 100%
(5/5) ファイルの衝突をチェック [######################] 100%
(5/5) 空き容量を確認 [######################] 100%
(1/5) 更新 catalyst-libgl [######################] 100%
--------------------------- PXP --------------------------------
@pxp_user: I switched GL/glx links to catalyst again...
----------------------------------------------------------------
(2/5) 更新 catalyst-utils [######################] 100%
-------------------------- TTY BUG -----------------------------
There's a bug in switching to VT/TTY
Using uvesafb is a workaround:
https://wiki.archlinux.org/index.php/uvesafb
----------------------------------------------------------------
catalyst-utils の新しい提案パッケージ
procps-ng: brings pgrep used in acpi event support [インストール済み]
(3/5) インストール linux-lts [######################] 100%
>>> Updating module dependencies. Please wait ...
>>> Generating initial ramdisk, using mkinitcpio. Please wait...
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
-> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
==> Starting build: 4.1.12-1-lts
-> Running build hook: [base]
-> Running build hook: [udev]
-> Running build hook: [autodetect]
-> Running build hook: [modconf]
-> Running build hook: [block]
-> Running build hook: [filesystems]
-> Running build hook: [keyboard]
-> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
-> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
==> Starting build: 4.1.12-1-lts
-> Running build hook: [base]
-> Running build hook: [udev]
-> Running build hook: [modconf]
-> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: wd719x
-> Running build hook: [filesystems]
-> Running build hook: [keyboard]
-> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
==> Image generation successful
linux-lts の提案パッケージ
crda: to set the correct wireless channels of your country
(4/5) インストール linux-lts-headers [######################] 100%
(5/5) 更新 catalyst-hook [######################] 100%
- removing fglrx module from /usr/lib/modules/4.1.12-1-lts
- removing fglrx module from /usr/lib/modules/4.1.6-1-ARCH
+ building fglrx module for 3.18.1-ARCH kernel ...
Failed!!! Check out log: /var/log/catalyst-install.log
+ building fglrx module for 4.1.12-1-lts kernel ...
ok.
+ building fglrx module for 4.1.6-1-ARCH kernel ...
ok.
------------------------- ANGELA -------------------------------
To enable 'automatic re-compilation while system shutdown/reboot'
feature run these commands as root:
systemctl enable catalyst-hook
systemctl start catalyst-hook

More info here:
https://bbs.archlinux.org/viewtopic.php?pid=1255575#p1255575
----------------------------------------------------------------
--------------------- NO 4.2 KERNEL SUPPORT---------------------
catalyst doesn't support linux kernels >= 4.2
please configure bootloader to use proper kernel
like linux-lts in example

sleeping now for 5 seconds as this is important...
----------------------------------------------------------------

catalystの動作は、問題なかった。システム的に
ロングタームサポートのltsカーネルを使ってくれ、
ってことのようだ。catalyst異常なし。

赤字は気にしなくていいんじゃないかな。


posted by ブログ開設者 at 13:55| Comment(0) | linux | このブログの読者になる | 更新情報をチェックする